Total outage for hotels search results

Incident Report for Click Travel Ltd

Resolved

We have identified the issue and resolved it immediately, we are sorry for any inconveniences caused. Thank you so much for your patience!
Posted Dec 05, 2025 - 18:23 GMT

Investigating

There is a total outage for search hotels and we are currently investigating this matter.
Posted Dec 05, 2025 - 17:59 GMT
This incident affected: Search (Hotel Search).