Booking.com channel outage

Incident Report for Click Travel Ltd

Resolved

We are now seeing successful bookings and therefore are resolving the incident.
Posted Dec 11, 2025 - 16:10 GMT

Monitoring

Our supplier has made a fix for the issue and we can see successful searches and bookings go through. We will continue to monitor.
Posted Dec 11, 2025 - 13:16 GMT

Investigating

We have identified an issue with Booking.com and are liaising with them to resolve.
Posted Dec 11, 2025 - 11:24 GMT
This incident affected: Search (Hotel Search).