Issue handling some Travelodges
Incident Report for Click Travel Ltd
Resolved
Our supplier has now applied a fix and we can now search, book and cancel rooms through Travelodge again.
Posted Oct 01, 2019 - 09:09 BST
Update
We are currently working with Travelodge to identify the cause of this issue.
Posted Sep 27, 2019 - 13:56 BST
Investigating
We are currently investigating an issue affecting our ability to communicate with Travelodge's Direct Connect. This may result in difficulties booking and cancelling Travelodges, as well as reducing the number of room options available
Posted Sep 27, 2019 - 10:44 BST
This incident affected: Search (Hotel Search) and Booking / Checkout.