Reduced availability of British Airways fares

Incident Report for Click Travel Ltd

Resolved

Our supplier has resolved their issue and all British Airways fares are available on the platform. Apologies for any inconvenience caused.
Posted Mar 19, 2025 - 09:03 GMT

Investigating

Due to an unplanned outage with a third party supplier we are seeing reduced availability of some British Airways fares. We are working with our supplier to understand the issue. If the fare you require isn't available, please try again and if the issue persists please contact customer support. We apologise for any inconvenience caused.
Posted Mar 18, 2025 - 17:22 GMT
This incident affected: Search (Flight Search).