Some British Airways bookings failing

Incident Report for Click Travel Ltd

Resolved

Our supplier has issued a notice that the issue has been resolved and we are no longer seeing any issues
Posted Jun 20, 2025 - 12:33 BST

Investigating

We are currently seeing an issue of a partial outage with making British Airways flights with some bookings failing on the platform. We apologise for any inconvenience.
Posted Jun 20, 2025 - 11:11 BST
This incident affected: Booking / Checkout.