Travelodge hotel bookings failing and/or failing to be cancelled.
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted Feb 07, 2023 - 16:45 GMT
Monitoring
The issue with our supplier causing Travelodge hotel bookings to fail and/or fail to be cancelled has stabilised and we are continuing to monitor it.
Posted Feb 07, 2023 - 14:44 GMT
Update
We are continuing to investigate this issue.
Posted Feb 07, 2023 - 12:56 GMT
Investigating
We are currently investigating an issue with Travelodge hotel bookings failing and/or failing to be cancelled.
Posted Feb 07, 2023 - 12:55 GMT
This incident affected: Booking / Checkout.