Intermittent failures making bookings through EasyJet
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 11:11 BST
Update
We are continuing to investigate this issue.
Posted Sep 17, 2021 - 11:11 BST
Investigating
We are investigating instability making bookings through the EasyJet channel causing intermittent booking failures.
Posted Sep 16, 2021 - 00:00 BST
This incident affected: Booking / Checkout.